Desktop version not's work on Monterey

  • I am trying to build apps for mac os x with Monterey OS.
    The app compiles but this error appears upon execution.


    I want to specify that I have installed Monterey on an old mac mini through a procedure seen on youtube, otherwise Monterey could not be installed as my mac is too old.
    While on Mac with OS Catalina the app works.

  • Sorry I'm not sure what it could be, I looked around and ppl on the web seem to get this whenever there's no OpenGL or whenever their stencil was not set to a nice 8-bit size before opening a new Window. So I doubledchecked the sourcecode of Cebrerus and found that it uses 8-bit so it's not the stencil.

    My guess is that Apple's internal mapping of Metal to OpenGL goes haywire when you do that kind of install on "old" hardware. But that's just what my inutition tells me, I have no idea exactly what the problem is.

    I use Monterey 12.4 on a 2015 macBook Air but I do have an old macbook air from 2012 I could test on. Let's see first if someone else recognizes the problem.

    Can you confirm that OpenGL works on everything else? Maybe even on cerberus binaries that you compiled on some other mac?

  • I am running CX on a 2014 MAc mini and compile to OSX Desktop just fine. Which version (Monterey and CX) are you using?
    Do the examples run? Somehow it can't create a window.
    Your machine must be VERY old because this one can be upgraded normally.

  • Could you please try to add this line to the glfwWindowHint lines above the window creation in XCode and see if that helps?

    C++
    glfwWindowHint(GLFW_OPENGL_FORWARD_COMPAT, GL_TRUE);
  • To bad. I am reading in the net that people had the first error you got even with older versions of OSX and the only solution was to downgrade to a lower OSX version.

    My last guess would be
    1. Remove the compabilty hint
    2. set the stencil buffer hint to 0

  • I solved it, now it works!
    I had not completed the procedure, I had forgotten a step.
    In addition, other problems such as window animation and some colors have been fixed.
    The error probably occurs only with this procedure that is used to install Monterey on unsupported machines, so in my opinion on new macs the problem should not exist.
    If you want I can post the link to the video but it is in my language, Italian, but there should also be videos in English.

  • Glad you got it working. But please don’t post such videos here. People will find them if they need to.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!