Cerberus 2017-10-24 no go on Mac

  • tried installing 2017-10-24

    Not going smoothly ! PERMISSION ISSUES still ! Cant create dir errors

    Error line 938 then comment character is incorrect , it looks good but throws an error in real life !

    Cerberus must be in the Applications folder otherwise icloud issues !

    More errors after moving Cerberus to documents folder where its gobbled my data backing it up to icloud.

    Duplicate identifier ‘Font’ found in module ‘graphics’ and module ‘fontinterface’

    Im re-installed previous working version, this one just wont work on my Mac

    Anyone got it going on Macs ?

    Currently i cant build or anything so I have stepped backwards, im going to try again next week, these hassles just wear me out !

    To make it worse Xcode 9.2 wont start installing just hangs with ‘waiting’ so I cant compile anything at all !

    Permissions ! Still not addressed....

  • On El-Capitan (10.11.6) it runs fine from within the applications folder. No changes in permissions were needed. But you need to delete or comment that like its complaining inside the graphics.cxs file as it seems a wrong character was used to comment that line out.

    Which OSX version do you use? I can't go to High Sierra as it doesn't support my system?

  • Im using High Sierra but xcode wont update just freezes saying ‘waiting’ but I could wait for hours , nothing ?

    Cerberus install just doesn’t go smoothly, its like Mark is still working on it , ie loads of simple failures but essentially could be a great product LOL ?

    Not being able to create a folder and having basics should be first above everything else at least someone had the common sense to get rid of the reference to “monkey apps” and hopefully they will get rid of the “game” reference and change that to “app” ie “cerberus app” so it can be seen for making “apps” a broader term, not everyone makes games.

    Short story is it dont work on Mac, immediately dissapointing and requiring hours to get it working.

    On top of this xcode wont start anymore because appearantly its updating (soon....) but appstore says still ‘waiting’ so I can no longer compile !

  • Yippeee it finally started downloading xcode ! The trick is it takes up to an hour to start,

    Once this finishes in 6 hours I will try and give more details on Cerberus

  • Eventually Martin or someone will be able to help. I simply can't cause my system is to old. Btw. Mr. Sibly has nothing to do with CX. At least that is what i heard last.

  • I have Cerberus back running again using previous version , non of the demo’s compile on the newest release.

    I can build now, with V2017-07-04 on Mac running High Sierra.

  • Wanting the terms “monkey” and “game” changed to “cerberus” and “app” is about personalising not taking a “poke” at anyone, just like wanting icons etc, they are needed for your programs to be taken seriously,

    I tried building the first example again on the new version of Cerberus on a Mac,

    Line 938; graphics.cxs
    Syntax error - unexpected token “ ‘ “ wrong character, not comment token.

    Also the mojo demo “matchup” no longer builds because of a duplicate identifier “Font” found in module ‘graphics’ and module ‘fontinterface’ in bitmapfont.cxs

    Also in “life.cxs” cannot convert from Font to image in line 238

    Obviously there is a clash with the new font stuff, should be an easy fix.

    Fix that (graphics.cxs) and it now builds (except for the demos mentioned).

    I can also report build times are WAY FASTER ! Huge decrease in build times for HTML it looks better, big improvement.

  • If you mean the error reported in graphics.cxs about an unknown character... just delete the line. Martin seems to have used the wrong character to REM out this line.

  • sorry a bit confused:confused:, line 938 was already commented out, can you tell me what line or block needs to be commented or rem'd out ty

    edit: also from what file, i was talking about graphics.csx

  • D:/Cerberus/examples/mojo/devolonter/matchup/fontmachine/bitmapfont.cxs<28> : Error : Duplicate identifier 'Font' found in module 'graphics' and module 'fontinterface'.

  • Damn. Another relic cause by improper 3rd party module naming. I will get back to you about this soon.

  • [QUOTE="Dubbsta, post: 2359, member: 38"]sorry a bit confused:confused:, line 938 was already commented out, can you tell me what line or block needs to be commented[/QUOTE]
    That line needs to be deleted. That character to comment it out is the wrong one.

  • I would love to hear from OSX users, if the permission problem is still a thing in the v2018-03-02 release.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!